Usenet Explorer

Forums
It is currently Sun Jun 16, 2019 2:34 pm

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Low virtual Memory
PostPosted: Wed Sep 21, 2005 5:01 am 

Joined: Tue May 17, 2005 5:52 pm
Posts: 17
This problem has happened twice. The first time, I reseted the database to get rid of the problem.

Right now, newspro is using 1.2GB of my memory (physical + virtual). What really makes this strange is the fact that the "Data" folder uses only 157MB and that I have only approx. 100,000 headers in all the newsgroup. When normally, I would only see 600MB of memory used for approx. 900,000 headers.

It seem like newspro is making a wrong decision based on some corrupted data. Maybe a file of the database is corrupted, but which one?

Newspro version: v3.9


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 21, 2005 5:40 am 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4412
does it happen on start and maybe you have many newsgroup windows open? is there specific activity is going on when the memory consumption increases? and if you minimize newspro, the memory should drop, is it going back to 1.2GB?

with all newsgroup windows closed newspro shouldn't take much more than the database limit, in short maybe 700KB, just by design when you restore database it needs double memory and 1.4GB is a practical limit for windows 32 bit systems

try to check with usenet explorer, make the newsgroup type "article numbers" so it will consume memory less but comparable to newspro, how much memory is consumed, just if it is high it might be something in the newsgroup itself.

it also might be connected to the system (then with usenet explorer you should see the same thing) if you have some memory accelerator running which caches everything (when downloading bodies a lot of data is coming through) or some kind of interference from third party software like antivirus.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 21, 2005 7:30 am 
>does it happen on start

The jump in memory happens about 10sec. after newspro starts.

>and maybe you have many newsgroup windows open?

No, no window open in newspro, almost no application running (about 100MB of memory used before starting newspro).

>and if you minimize newspro, the memory should drop, is it going back
>to 1.2GB?

The 1.2GB stays the same, but about 100Mb is shipped from memory to swap file.

>with all newsgroup windows closed newspro shouldn't take much more
>than the database limit

After multiple start and close whitout any problems, the problem is still there.

>try to check with usenet explorer

I bought it and I will try it in the next few days.

This is my usual use of newspro: about twice a week a get headers from newsfeeds. I have only 512MB RAM, so once I've reached about 500,000 headers I cancel getting headers (because at about 6,000,000 headers it would stop getting them, flush everyting and exit whitout saving any headers) and I delete the unwanted ones. I then close the window and reopen it to flush the deleted headers. Then I repeat the process until I got all the headers downloaded. Then I download the articles and delete everything after I saved the attachments.

The last time I reseted the database was about 2 months ago and there were the occasional crashs (windows XP!!!) while using newspro (about 5 or 6 times).


Top
  
 
 Post subject:
PostPosted: Wed Sep 21, 2005 7:33 am 

Joined: Tue May 17, 2005 5:52 pm
Posts: 17
Note: the last post was mine.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 21, 2005 3:13 pm 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4412
you may email me errorlog.txt or if it is the same crash address - paste it here, maybe something will be clear from the report.

usenet explorer doesn't have any problem to download 6M headers for compact binary newsgroup destination type within 512M RAM (I think you can handle about 50M+ headers in loaded groups and the rest unloaded), with 512M RAM and article numbers destination type it will handle a little more (maybe 20% headers) than newspro.

the problem is newsfeeds had some issues for several months so you may get 'no such article' (see related thread in the ue support section). you may experience the problem or not, it depends what newsgroups are corrupted on newsfeeds front end.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 25, 2005 5:46 pm 

Joined: Tue May 17, 2005 5:52 pm
Posts: 17
>you may email me errorlog.txt or ...

I looked it to it and there is nothing that does look out of the ordinary.

> ... or if it is the same crash address

Windows did crach a few time, but i don't think its related to NewsPro. When NewsPro did quit on me, it usually was with a nice message and closed cleanly (but did save any work done. I think).

> usenet explorer doesn't have any problem to download 6M headers for
> compact binary newsgroup

I have seen the light! :)

I've tried it and I'm never comming back to NewsPro. In the end I was thinking of making my own NNTP client. Mostly because of the monolithique used of the memory, but the loading and the unloading of the newsgroup in UE is great.

And most of all, it's the lightspeed fast. I've nerver seen my bandwidth being used to its full capacity and staying there for the completion of my download.

Congratulation on this great achivment. It's well worth the money! :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group