Usenet Explorer

Forums
It is currently Tue May 22, 2018 4:25 am

All times are UTC




Post new topic Reply to topic  [ 24 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Gigabit internet service and usenetexplorer
PostPosted: Fri Apr 28, 2017 3:12 pm 

Joined: Fri Apr 28, 2017 4:45 am
Posts: 14
Hi - so I was lucky enough to get gigabit Verizon fios service yesterday and I have been doing lots of testing with it. The first thing I tried was newsgroups of course and I was very disappointed when using usenetexplorer. Downloading I hover at about 32 MB a second. I know something is wrong with either the program or maybe my settings because when I use NZB get (the newgroup downloading software) I get a stable 74 MB a second download. Can anyone help me figure out how to get the same speed with usenetexplorer? I want to keep using that, but if I can't I am gonna have to start using NZB get.

The only settings I tried changing was the max number of tasks for the server properties. My server allows 20 connections to it, so I set max tasks to 20. After that didn't help I upted it to 40... still no change.

I know gigabit is not wide spread so I am wondering if I am a first test case here for usenetexplorer. Thanks.


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 3:49 am 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4364
Is edit menu->properties->save/unpack, save, bypass database storage and optimize are checked?

Is edit menu->properties->general, severs, keep connections alive checked?

It also might be the timer, I could increase the frequency or add it as parameter in properties and we could check it out.

Did you try to reduce the number of tasks? Try to reduce it to 10, then 5 and record what is the speed, if it is timer it should drop proportionally.

Timer currently 1/20 second, so for example if part is 100kb 20 tasks = 2mb * 20 = 20MB/s, if 1MB - 200MB/s. Can you check what is the part size or give me an example of a download?

In any case we need to check it first here with a test version to see if it is really the cause.


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 3:58 am 

Joined: Fri Apr 28, 2017 4:45 am
Posts: 14
Yes all of those are checked as you asked.

When I change the number of tasks to 10 the speed is lowered from the max of 33MB/s to about 25MB/s. When I change to 5 is lowers to 16MB/s. If I bump the tasks higher than 20 it doesn't make any difference in the speed. Using windows resource monitor - when downloading on usenetexplorer at 35MB/s it equates to about 279Mbps (gigabit is close to 1000Mbps).

The one I was testing on is 1.26m Lines, 154MB size, and 204 Parts/Files. Does this help? I can send you the .nzb I was trying to import.


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:00 am 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4364
ok I"ll try to recompile and we'll check it, I'll give you a link in a moment.


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:02 am 

Joined: Fri Apr 28, 2017 4:45 am
Posts: 14
alex wrote:
ok I"ll try to recompile and we'll check it, I'll give you a link in a moment.


Thanks - I just edited my post on the last question you had on parts.


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:10 am 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4364
try this one:

http://www.usenetexplorer.com/temp/ue503b32.zip

http://www.usenetexplorer.com/temp/ue503b64.zip

check them both (32 bit and 64 bit versions).

you can just launch them from the zip file.

the frequency is 5 times higher.

I can also add it to properties, but we will see first if it is the cause.

Parts I mean how many parts in every file, a post contains files, but every file (partial message) consist of separate articles (single messages).


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:14 am 

Joined: Fri Apr 28, 2017 4:45 am
Posts: 14
alex wrote:
try this one:

http://www.usenetexplorer.com/temp/ue503b32.zip

http://www.usenetexplorer.com/temp/ue503b64.zip

check them both (32 bit and 64 bit versions).

you can just launch them from the zip file.

the frequency is 5 times higher.

I can also add it to properties, but we will see first if it is the cause.



Thanks but no change. Still downloading at the 34MB/s.


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:21 am 

Joined: Fri Apr 28, 2017 4:45 am
Posts: 14
alex wrote:
try this one:

http://www.usenetexplorer.com/temp/ue503b32.zip

http://www.usenetexplorer.com/temp/ue503b64.zip

check them both (32 bit and 64 bit versions).

you can just launch them from the zip file.

the frequency is 5 times higher.

I can also add it to properties, but we will see first if it is the cause.

Parts I mean how many parts in every file, a post contains files, but every file (partial message) consist of separate articles (single messages).



Ok so when I select show parts it shows this... 6.19k Lines, 773 KB size, and single as parts/files


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:22 am 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4364
What is the hard drive type?

What is the program CPU usage when downloading, low?

Then try to increase edit menu->properties->tasks, network threads, system priority (middle, bottom) to above normal, do you see any change?

Keep alive, bypass database storage and optimize all are checked?


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:29 am 

Joined: Fri Apr 28, 2017 4:45 am
Posts: 14
alex wrote:
What is the hard drive type?

What is the program CPU usage when downloading, low?

Then try to increase edit menu->properties->tasks, network threads, system priority (middle, bottom) to above normal, do you see any change?

Keep alive, bypass database storage and optimize all are checked?



CPU goes from 2% to 30% when I start a download - only drive in the system is a Samsung 940 EVO SSD

When I change to "above normal" cpu drops to 28% with no change in download speed.

Keep alive, bypass database storage and optimize are all checked


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:31 am 

Joined: Fri Apr 28, 2017 4:45 am
Posts: 14
alex wrote:
What is the hard drive type?

What is the program CPU usage when downloading, low?

Then try to increase edit menu->properties->tasks, network threads, system priority (middle, bottom) to above normal, do you see any change?

Keep alive, bypass database storage and optimize all are checked?



Thanks for this help by the way - I realize that not many people have gigabit, so I am sure this is an odd case that you are seeing.


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:34 am 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4364
Do you have any antivirus or firewall which scans incoming traffic?

If so can you try first to exclude UE from the scan?

CPU usage rises for the UE process?


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:47 am 

Joined: Fri Apr 28, 2017 4:45 am
Posts: 14
alex wrote:
Do you have any antivirus or firewall which scans incoming traffic?

If so can you try first to exclude UE from the scan?

CPU usage rises for the UE process?


Oh my gosh - as soon as I turned off windows defender the download jumps up to about 55MB/s - That definitely makes a difference - still not as fast as it should be but its a great find.
I also made an entry to allow UE on firewall - that didn't seem to make a difference.


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:48 am 

Joined: Thu Feb 27, 2003 5:57 pm
Posts: 4364
The file buffer size is already 500KB, so basically with 700KB chunks it is only couple of writes.

Maybe to try to increase socket buffer size then, they are above the network threads priority option (edit menu->properties->tasks, set socket buffers).

First (if checked) try to uncheck both read write socket buffers to use the default size.

Then check again and them both e.g. to 65536 and check if there will be any change.

Did you run this version above? - 55MB/s, the timer may play a role.


Top
 Profile  
 
 Post subject: Re: Gigabit internet service and usenetexplorer
PostPosted: Sat Apr 29, 2017 4:58 am 

Joined: Fri Apr 28, 2017 4:45 am
Posts: 14
alex wrote:
The file buffer size is already 500KB, so basically with 700KB chunks it is only couple of writes.

Maybe to try to increase socket buffer size then, they are above the network threads priority option (edit menu->properties->tasks, set socket buffers).

First (if checked) try to uncheck both read write socket buffers to use the default size.

Then check again and them both e.g. to 65536 and check if there will be any change.

Did you run this version above? - 55MB/s, the timer may play a role.



I changed the socket sizes and I am using the above version - download seems to be fluctuating from anywhere from 51MB/s to as high as 64 MB/s. I had to create an exclusion entry in windows defender to exclude the whole usenetexplorer directory.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 24 posts ]  Go to page 1, 2  Next

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group